Skip to main content

Techdocs Library > Flashes >

Meeting the IBM Tivoli Monitoring Pre-requisite for libstdc++.so.5 on Linux for z Systems distributions that don’t provide this older library



Document Author:

Michael Sine


Document ID:

FLASH10871


Doc. Organization:

Advanced Technical Sales


Document Revised:

12/15/2016


Product(s) covered:

Tivoli Monitoring; Tivoli OMEGAMON XE for z/VM and Linux







Abstract: When installing IBM Tivoli Monitoring (ITM) components on many of the latest Linux on z Systems distributions (ex SLES 12.x or RHEL 7.x) it is common to run into a pre-requisite issue related to the missing library libstdc++.so.5. These later Linux distributions ship with libstdc++.so.6. This flash is meant to be a quick example showing one way to resolve this issue in hopes it helps you continue with your installation of IBM ITM.

ITMinstallPreReq_libstdc_so_5.pdfITMinstallPreReq_libstdc_so_5.pdf



Classification:

Software

Category:

Installation and Migration

Solution(s):

Cloud



Platform(s):

IBM System z Family

S/W Pillar(s):

IBM System z Software; Tivoli

O/S:

Linux

Keywords:

libstdc++.so.5, pre-requisite, OMEGAMON XE on z/VM and Linux, ITM, IBM Tivoli Monitoring, Linux OS agent, lz agent, ITM, 6.3.0, Fixpack 6, FP6, Linux on z Systems


The Techdocs Library
Is this your first visit to Techdocs (the Technical Sales Library)?

Learn more


Techdocs QuickSearch

: