Skip to main content

Techdocs Library > Hints, tips & Technotes >

PowerHA for AIX Version Compatibility Matrix



Document Author:

Michael E Herrera


Document ID:

TD101347


Doc. Organization:

Advanced Technical Sales


Document Revised:

09/07/2016


Product(s) covered:

PowerHA SystemMirror







Abstract: This document is a quick cross reference between the supported versions of HACMP and AIX.

Last updated September 7, 2016
HACMP Version
Supported?
MIN AIX Level(s)
MISC
1.2
NO
3.2.5
2.1
NO
3.2.5
3.1.0
NO
3.2.5
3.1.1
NO
3.2.5
4.1.0
NO
4.1.X
4.1.1
NO
4.1.X
4.2
NO
4.1.4, 4.2.X
4.2.1
NO
4.1.5, 4.2.X
4.2.2
NO
4.1.5, 4.2.1, 4.3.X
4.3
NO
4.3.2, 4.3.3
4.3.1
NO
4.3.2, 4.3.3
4.4
NO
4.3.3
4.4.1
NO
4.3.3, 5.1
4.5
NO
5.1, 5.2
5.1
NO
5.1, 5.2,5.3
5.2
NO
5.1, 5.2,5.3
NO
5.2(ML4), 5.3(ML2) or higher
6.1
AIX 5.2 RSCT 2.3.6 or higher
AIX 5.3 RSCT 2.4.2 or higher
5.4.0
and
5.4.1
NO
5.2 (TL8) or higher
5.3
(TL4) or higher
AIX 5.2 RSCT 2.3.9 or higher
AIX 5.3 RSCT 2.4.5. or higher
5.3 TL7
6.1 TL2,SP1

AIX 7.1
AIX 5.3 RSCT 2.4.10.0 or higher
AIX 6.1 RSCT 2.5.2.0 or higher

release_notes
6.1 (5765-H24)
No – 4/30/2015
AIX 5.3 TL 9
AIX 6.1 TL2 SP1

AIX 7.1
or later
AIX 5.3 RSCT 2.4.12.0 or higher
AIX 6.1 RSCT 2.5.4.0 or higher
release_notes
7.1.0
(5765-H39)
No
AIX 6.1 TL6+
AIX 7.1
or later
AIX 6.1 RSCT 3.1.0.0 or higher
AIX 7.1 RSCT 3.1.0.0
release_notes
7.1.1
(5765-H39)
No
AIX 6.1 TL7 SP2
AIX 7.1 TL1 SP2
or later
RSCT 3.1.2.0 or higher for both AIX versions
release_notes
7.1.2
(5765-H39)
No
AIX 6.1 TL8 SP1
AIX 7.1 TL2 SP1
or later
Hyperswap requires APAR IV27586
release_notes
7.1.3
(5765-H39)
Yes
AIX 6.1 TL9 SP1
AIX 7.1 TL3 SP1
or later
Recommended Levels
7.2.0
(5765-H39)
Yes
AIX 6.1 TL9 SP5
AIX 7.1 TL3 SP5
AIX 71 TL4 SP1
AIX 7.2 SP1
Recommended Levels
                  * Note that levels documented were the levels tested at the time of the HA release. Subsequent AIX releases like AIX 7.2 if not specifically mentioned in the table should just work but may not have undergone extensive testing with that release


Upgrade path options: (last updated Q2 2016)

Recommended Levels

PowerHA SystemMirror 7.1.3 SP4
AIX 6.1.9 SP6 or
AIX 7.1.3 SP6
PowerHA SystemMirror 7.2
AIX 6.1.9 SP6 or
AIX 7.1.3 SP6 or
AIX 7.1.4 SP1 or
AIX 7.2 SP1

Tips and guidelines for V7 migrations can be found at the following URL:
https://aix.software.ibm.com/aix/ifixes/PHA_Migration/ha_install_mig_fixes.htm

Key Dates:
  • V6.1.0 EOS - 4/30/2015 Extended Support Option till: 4/30/2018
  • V7.1.0 EoSP - 9/30/2014
  • V7.1.1 EoSP - 4/30/2015
  • V7.1.2 EoSP - 4/30/2016
  • V7.1.3 EoSP - 4/30/2018
  • V7.2.0 EoSP - 4/30/2019
Ver 5.4.1
Ver 5.5
Ver 6.1
Ver 7.1.1
Ver 7.1.2
Ver 7.1.3
Ver 7.2
5.4
R/S/O/N
R/S/O/N*
R*/S/O*/**
Upgrade to V6.1 and then to V7
5.4.1
NA
R/S/O/N
R/S/O/N
5.5
NA
NA
R/S/O/N
6.1
NA
NA
NA
R/S/O
R/S/O
R/S/O
R/S/O
7.1.0
NA
S/O
S/O
S/O
S/O
7.1.1
NA
R/S/O
R/S/O
R/S/O
7.1.2
NA
NA
R/S/O
R/S/O
7.1.3
NA
NA
NA
N/R/S/O

R=Rolling Upgrade
S=Snapshot Upgrade
O=Offline Upgrade
N=Non-disruptive Upgrade

*= Must upgrade to 5.4.1 or above first, making it a two step upgrade.
**=NDU not officially supported beyond two versions



Minimum AIX Levels Required for Installation:

Supported
AIX 4.3.3
AIX 5.1
AIX 5.1(64-bit)
AIX 5.2
AIX 5.3
AIX 6.1
AIX 7.1
AIX 7.2
HACMP 4.5
X
No
Yes
No
Yes
No
No
No
No
HACMP/ES 4.5
X
No
Yes
Yes
Yes
No
No
No
No
HACMP/ES 5.1
X
No
Yes
Yes
Yes
Yes
No
No
No
HACMP/ES 5.2
X
No
Yes
Yes
Yes
Yes
No
No
No
HACMP/ES 5.3
X
No
No
No
Yes
Yes
No
No
HACMP/ES 5.4.0
X
No
No
No
TL8+
TL4+
No
No
No
X
No
No
No
TL8+
TL4+
No
X
No
No
No
No
TL9+
TL2,SP1+
No
X
No
No
No
No
TL9+
TL2,SP1+
SP1
X
No
No
No
No
No
TL6+
SP1
X
No
No
No
No
No
TL7+
TL1 SP2
SP1
X
No
No
No
No
No
TL8 SP1
TL2 SP1
SP1
Y
No
No
No
No
No
TL9 SP1
TL3 SP1
SP1
Y
No
No
No
No
No
TL9 SP5
TL3 SP5
TL4 SP1
SP1



Classification:

Software

Category:

Planning and Design




Platform(s):

IBM Power Systems



O/S:

AIX

Keywords:

HACMP PowerHA SystemMirror

The Techdocs Library
Is this your first visit to Techdocs (the Technical Sales Library)?

Learn more


Techdocs QuickSearch

: