Mixed-language transaction processing for distributed platforms

Download V9.1


IBM® TXSeries® for Multiplatforms is distributed transaction processing middleware. It supports C, C++, COBOL, Java™ and PL/I applications in cloud environments and traditional data centers. It is designed to provide a scalable and highly available platform to develop, deploy and host mission-critical applications. It integrates well into a mixed-language, hybrid cloud solution, with support for RESTful APIs

TXSeries for Multiplatforms provides:

Distributed transaction management capabilities to provide a robust, scalable and secure platform for business applications.

Workload management, availability and performance features to improve productivity and support business growth.

Management, monitoring and administration features to ease administration and enhance security.

CICS and non-CICS family interoperability for enhanced scalability and flexibility.

Serviceability capabilities that offer extensive diagnostic tools for problem determination and remediation.

Exposing applications as RESTful APIs. This release enables clients to participate in the API Economy by exposing their existing applications as RESTful APIs


Blogs: Do more with TXSeries

TXSeries for Multiplatforms resources

System requirements for V9.1

Operating System Software Hardware
AIX

AIX IBM AIX ® 7.1 TL4 or AIX 7.2

Most supported IBM and Third Party software for TXSeries V9.1 on IBM AIX

Any IBM eServer™ pSeries hardware that is capable of running AIX.

System requirements for V8.2

Operating System Software Hardware
Linux

Red Hat Enterprise Linux V5.9, V6.4 and SUSE Linux Enterprise V11 SP 3 or Ubuntu 14.04 on x86 architecture

Most supported IBM and Third Party software for TXSeries V8.2 on Linux.

Any x86-based hardware that is capable of running Red Hat Enterprise Linux, SUSE Linux Enterprise or Ubuntu.

AIX

AIX 6.1 TL9 and AIX 7.1 TL3

Most supported IBM and Third Party software for TXSeries V8.2 on IBM AIX.

Any IBM eServer™ pSeries hardware that is capable of running AIX.

Windows

Microsoft Windows Server 2012 and Microsoft Windows Server 2012 R2

Most Supported IBM and Third Party Software for TXSeries V8.2 on Windows.

Any x86-based hardware capable of running Microsoft Windows Server.

HP-UX

HP-UX 11i V3 (B.11.31.0909) on HP Integrity Platform

Most supported IBM and Third Party software for TXSeries V8.2 on HP-UX on HP integrity Platform.

Any HP-UX Integrity compatible hardware that is capable of running HP-UX.

System requirements for V8.1

Operating System Software Hardware
Linux Red Hat Enterprise Linux V5.8, V6.3 and SUSE Linux Enterprise V11 SP 2 on X86 architecture

Most supported IBM and Third Party software for TXSeries V8.1 on Linux.
Any x86-based hardware that is capable of running Red Hat Enterprise Linux or SUSE Linux Enterprise.
AIX AIX 6.1 TL8 and AIX 7.1 TL2

Most supported IBM and Third Party software for TXSeries V8.1 on IBM AIX.
Any IBM eServer™ pSeries hardware that is capable of running AIX.
Solaris Solaris V10 UP9

Most supported IBM and Third-Party software for TXSeries V8.1 for Oracle Solaris.
Any SPARC hardware that is capable of running Oracle Solaris.
Windows Microsoft Windows Server 2008 SP2, 2008 R2 SP1, and Microsoft Windows Server 2012

Most supported IBM and Third-Party software for TXSeries 8.1 for Microsoft Windows.
Any x86-based hardware capable of running Microsoft Windows Server.
HP-UX HP-UX 11i V3 on HP Integrity Platform

Most supported IBM and Third-Party software for TXSeries V8.1 for HP-UX on HP Integrity Platform.
Any HP-UX Integrity compatible hardware that is capable of running HP-UX.

System requirements for V7.1

Operating System Software Hardware
AIX AIX V5.3 TL7 or AIX 6.1 TL2

Supported IBM and vendor-acquired software with TXSeries for Multiplatforms 7.1 on IBM AIX.
IBM eServer™ pSeries® hardware capable of running AIX.
Solaris SUN Solaris V10

Supported IBM and third-party software with TXSeries for Multiplatforms 7.1 on Sun Solaris.
Any SPARC hardware that is capable of running Oracle Solaris.
Windows Microsoft Windows Server 2003 or Microsoft Windows Server 2008

Supported IBM and third-party software with TXSeries for Multiplatforms 7.1 on Microsoft Windows.
Any x86-based hardware capable of running Microsoft Windows Server.
HP-UX(PA-RISC and Integrity) HP-UX V11i V2 or V3

Supported IBM and Third-Party software for TXSeries V8.1 for HP-UX on HP Integrity Platform.

Supported IBM and third-party software with TXSeries for Multiplatforms 7.1 on HP-UX PA-RISC.
Any HP-UX (PA-RISC or Integrity) compatible hardware capable of running HP-UX.

Not in Netherlands?

Wij staan klaar om u te helpen

Koop online of verneem meer.