Increase productivity with an Enterprise Generation Language development platform

IBM® Rational® Business Developer is an Eclipse-based integrated development environment (IDE) that simplifies the development of service-oriented architecture (SOA) applications using the Enterprise Generation Language (EGL). Developers can now deliver web, Web 2.0 and mobile applications and services without having to master Java and SOA programming, allowing them to create, test and debug EGL applications while generating Java, Javascript or COBOL code for deployment. RPG and COBOL developers can transition to EGL easily, as it allows them to create portable applications with modern architectures and user interfaces, without having to learn concepts of object-oriented languages.

Rational Business Developer simplifies development, providing developers with a single language for:

EGL transformation

Simplified service creation

Multiplatform deployment

UML support

Extensible platform

Rational Business Developer resources

Buy Rational Business Developer

Increase productivity with an Enterprise Generation Language development platform

IBM Software Subscription and Support is included in the product price for the first year.

Download software online after purchase - no shipping costs.


Rational Business Developer
Operating System Software Hardware
Java SDK 6.0 (included)

Supported databases:

IBM CICS Transaction Gateway V7.1 or later is required for remote calls to CICS
Processor: Intel Pentium III 800 MHz minimum
Memory: Memory: 2GB RAM minimum, 3GB recommended
Disk space: Minimum 1 GB of disk space is required for product package installation. Additional disk space is required for the resources that you develop. Note: Disk space requirements can be reduced or increased depending on the features that you install.
Display: 1024X768 minimum, 1280X1024 recommended
Generated Java
Operating System Software Hardware
z/OS V1.10 and later

IBM i V5.4 and later

IBM AIX® V6.1

Windows XP, Windows 2008, Windows Vista or Windows 7

Linux (Red Hat 5 or 6, or SUSE 10 or 11)

HP Unix 11iv2

Solaris 9 and later
Java/JRE 5.0 (or 1.5) or later is required in all supported environments

Web applications require WebSphere Application Server 6.1, 7.0, 8.0, and 8.5, Apache Tomcat 6.0 or 7.0, or the IBM i Integrated Application Server.

Generated JavaScript
Operating System Software Hardware
Microsoft Internet Explorer 7.0 and later

Mozilla Firefox 5 and later

Apple Safari 5 and later

Google Chrome 19 and later
Firefox 3.0 and later

Microsoft Internet Explorer 6.0 and later (version 8.0 or later recommended)

Safari 4 & 5

Google Chrome

Generated COBOL
Operating System Software Hardware
IBM z/OS V1.10 and later CICS Transaction Server for z/OS version 3.1 and later. Note: for Channel/Container support from remote ECI client calls, version 3.2 is required.

IBM IMS Transaction Manager version 9 and later

IBM Rational COBOL Runtime for zSeries V6.0.1 with latest PTFs

IBM Enterprise COBOL for z/OS 3.4 or later

IBM i V5.4 and later EGL COBOL Runtime (QEGL library included with Rational Business Developer)

Increase productivity for SOA application development with an EGL platform

IBM® Rational® Business Developer version 9.0 is based on Eclipse level 4.2.2. Desktop operating system support has been updated to include Windows 8 and Ubuntu 12.04 TLS.

Rational Business Developer V9.0 updates include:

More

Not in Nederland?

Koop online of verneem meer.

Wij staan klaar om u te helpen

Koop online of verneem meer.