モバイル・アプリの脆弱性の特定および修正

セキュリティー・ホールを開発段階で潰す!
MobileFirst Platform


IBM MobileFirst Platform Application Scanning では、モバイル・アプリのソース・コードの脆弱性をソフトウェア開発ライフサイクルの初期に特定し、実装前に修正できるようにすることで、組織のコストの削減とリスクの軽減を実現します。

IBM MobileFirst Platform Application Scanning は、アプリケーション・セキュリティー・テストをソフトウェア開発ライフサイクルに組み込みます。また、モバイル・アプリのスキャン機能を強化し、モバイル・アプリのテストをサポートします。これには、JavaScript、HTML5、Cordova、Java、Objective-C のサポートが含まれます。IBM MobileFirst Platform Application Scanning は、IBM MobileFirst Studio との統合および MobileFirst アプリケーションをスキャンする機能も提供します。

IBM MobileFirst Platform Application Scanning により以下のことが可能になります:

より強力でより包括的なソフトウェア・セキュリティー

統合によるインテリジェンスの向上

セキュリティーのベスト・プラクティスの実現

ガバナンスとコンプライアンスの保証

IBM MobileFirst Platform Application Scanning に関する参照情報

サポート OS / ソフトウェア
セキュリティー・テストの言語サポート Windows および Linux:
Java、Android、JavaScript (IBM MobileFirst Platform Foundation プロジェクト生成の JavaScript のみ)、JSP、C、C++、.NET (C#、ASP.NET、および VB.NET)

OS X:
Xcode プロジェクトの Objective-C、Java、Android、JavaScript (IBM MobileFirst Platform Foundation プロジェクト生成の JavaScript のみ)、JSP
IDE プラグインおよびプロジェクト・ファイル・スキャン・サポート Windows:
Eclipse バージョン 3.6、3.7、3.8、4.2、4.2.x、4.3、4.3.1、4.3.2、および 4.4。
IBM Rational Application Developer (RAD) V8.0.x、V8.5、V8.5.1、V8.5.5、V9.0、および V9.0.1。
Visual Studio 2008 (Standard、Professional、および Team Suite)、Visual Studio 2013 (Professional、Premium、および Ultimate)。
Visual Studio は C++、C#、ASP.NET、および VB.NET をサポートします。Eclipse および RAD は Java (Android を含む)、JavaServer Pages (JSP)、および IBM MobileFirst プロジェクトのスキャンをサポートします。

Linux:
Eclipse バージョン 3.6、3.7、3.8、4.2、4.2.x、4.3、4.3.1、4.3.2、および 4.4。
IBM Rational Application Developer (RAD) V8.0.x、V8.5、V8.5.1、V8.5.5、V9.0、および V9.0.1。
Eclipse および RAD は Java (Android を含む)、JavaServer Pages (JSP)、および IBM MobileFirst プロジェクトのスキャンをサポートします。

OS X:
Eclipse バージョン 3.6、3.7、3.8、4.2、4.2.x、4.3、4.3.1、4.3.2、および 4.4。
IBM Rational Application Developer (RAD) V9.0 および V9.0.1。
Eclipse および RAD は Java (Android を含む)、Xcode プロジェクトの Objective-C、JavaServer Pages (JSP)、および IBM MobileFirst プロジェクトのスキャンをサポートします。
ライセンス・サーバー IBM Rational License Server バージョン 8.1.1、8.1.2、8.1.3、および 8.1.4 (フローティング・ライセンスによって有効にする場合)

各国語への翻訳

国外にお住まいの方

お問い合わせはこちら

まずはお気軽にご相談ください